SIP softphone

Posted by Jim Jagielski on Thursday, April 3. 2008 in Technology

When I updated to Leopard 10.5.2, X-Lite no longer worked, so I needed to purchase eyeBeam. Anyway, the latest version of eyeBeam is out: So is another build of X-Lite, which may, or may not, work with 10.5.2.

Page 1 of 1, totaling 1 entries


Search for an entry in IMO:

Did not find what you were looking for? Post a comment for an entry or contact us via email!